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Amigo(a) estudante!

O Ministério da Educação vem desenvolvendo Políticas e Programas para ex-

pansão da Educação Básica e do Ensino Superior no País. Um dos caminhos 

encontrados para que essa expansão se efetive com maior rapidez e eficiên-

cia é a modalidade a distância. No mundo inteiro são milhões os estudantes 

que frequentam cursos a distância. Aqui no Brasil, são mais de 300 mil os 

matriculados em cursos regulares de Ensino Médio e Superior a distância, 

oferecidos por instituições públicas e privadas de ensino.

Em 2005, o MEC implantou o Sistema Universidade Aberta do Brasil (UAB), 

hoje, consolidado como o maior programa nacional de formação de profes-

sores, em nível superior. 

Para expansão e melhoria da educação profissional e fortalecimento do En-

sino Médio, o MEC está implementando o Programa Escola Técnica Aberta 

do Brasil (e-TecBrasil). Espera, assim, oferecer aos jovens das periferias dos 

grandes centros urbanose dos municípios do interior do País oportunidades 

para maior escolaridade, melhores condições de inserção no mundo do tra-

balho e, dessa forma, com elevado potencialpara o desenvolvimento produ-

tivo regional.

O e-Tec é resultado de uma parceria entre a Secretaria de Educação Profissio-

nale Tecnológica (SETEC), a Secretaria de Educação a Distância (SED) do Mi-

nistério daEducação, as universidades e escolas técnicas estaduais e federais.

O Programa apóia a oferta de cursos técnicos de nível médio por parte das 

escolas públicas de educação profissional federais, estaduais, municipais e, 

por outro lado,a adequação da infra-estrutura de escolas públicas estaduais 

e municipais.

Do primeiro Edital do e-Tec Brasil participaram 430 proponentes de ade-

quação de escolas e 74 instituições de ensino técnico, as quais propuseram 

147 cursos técnicosde nível médio, abrangendo 14 áreas profissionais.  

O resultado desse Edital contemplou 193 escolas em 20 unidades fede-
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rativas. A perspectiva do Programa é que sejam ofertadas10.000 vagas, 

em 250 polos, até 2010.

Assim, a modalidade de Educação a Distância oferece nova interface para 

amais expressiva expansão da rede federal de educação tecnológica dos úl-

timos anos: aconstrução dos novos centros federais (CEFETs), a organização 

dos Institutos Federaisde Educação Tecnológica (IFETs) e de seus campi.

O Programa e-Tec Brasil vai sendo desenhado na construção coletiva e par-

ticipação ativa nas ações de democratização e expansão da educação pro-

fissional no País,valendo-se dos pilares da educação a distância, sustentados 

pela formação continuidade professores e pela utilização dos recursos tec-

nológicos disponíveis.

A equipe que coordena o Programa e-Tec Brasil lhe deseja sucesso na sua 

formação profissional e na sua caminhada no curso a distância em que está 

matriculado(a).

Brasília, Ministério da Educação – setembro de 2008.
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Palavra do professor-autor
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A grade do curso Técnico em Informática para Internet foi elaborada cuida-

dosamente para formar profissionais qualificados e capacitados para ingres-

sar no mercado de trabalho. 

A disciplina ANIMAÇÃO PARA WEB tem como objetivo principal criar e edi-

tar animações multimídia em diversos formatos e publicar animações para 

aplicação em Multimídia(CD-ROM) e Web.

Esperamos contribuir para seu crescimento, oportunizando a vivência de ex-

periências interessantes, prazerosas e enriquecedoras.

Para que tenhamos êxito, sua participação é fundamental. Algumas atitudes 

positivas são essenciais para seu sucesso:

• Acredite em seu potencial.

• Reconheça suas dificuldades e falhas. Enfrente-as com coragem e esforço.

• Organize-se para estudar. Um local adequado, horários pré-estabelecidos e 

material didático selecionado favorecem o bom rendimento.

• Habitue-se a ler jornais, revistas, livros. Interpretar, analisar, discutir e rela-

cionar informações são habilidades importantes exigidas para compreensão 

desta e das outras disciplinas.

• Faça as tarefas e atividades propostas pelos tutores e professores.

• Nas atividades em grupo, expresse suas opiniões, mas também ouça seus 

colegas com respeito e atenção.

• A participação nas atividades trará benefícios essenciais na sua vida.

• Tire sempre suas dúvidas e não deixe o conteúdo se acumular.

Sucesso a todos!
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Indicação de Ícone

Os ícones são elementos gráficos utilizados para ampliar as formas de lin-

guagem e facilitar a organização e a leitura hipertextual

Atenção: indica pontos de maior relevância no texto.

Saiba mais: oferece novas informações que enriquecem o assunto ou 
“curiosidades” e notícias recentes relacionadas ao tema estudado.

Glossário: indica a definição de um termo, palavra ou expressão utilizada 
no texto.

Mídias Integradas: remete o tema para outras fontes: livros, filmes, músi-
cas, sites, programas de TV.

Atividades de aprendizagem: apresenta atividades em diferentes níveis 
de aprendizagem para que o estudante possa realizá-las e conferir o seu 
domínio do tema estudado.
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Apresentação da Disciplina
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A Disciplina ANIMAÇÃO PARA WEB possui carga horária de 60 horas que 

serão distribuídas dentro das semanas previstas no calendário do curso.

COMPETÊNCIAS DA DISCIPLINA

• Criar e editar animações multimídia em diversos formatos (incluindo o 

SWF)

• Criar imagens vetoriais com animação, som e interatividade

• Publicar animações para aplicação em Multimídia(CD-ROM) e  Web.

HABILIDADES

• Atualizar informações gráficas e textuais.

• Especificar recursos e estratégias de comunicação e comercialização.

• Adaptar conteúdo para mídias interativas.

• Definir interface de comunicação e interatividade.





Aula I - Técnicas de animação

INTRODUÇÃO

Animação é a técnica pela  qual se cria a ilusão do movimento atra-

vés da apresentação de uma série de desenhos fotografados ou de-

senhados individualmente e armazenados em sucessivos quadros de 

um filme. A ilusão é produzida no momento em que o filme é pro-

jetado a uma certa taxa de velocidade.

O computador começou a ser utilizado como ferramenta de apoio 

na criação de filmes na década de 60. Desde então, a animação por 

computador vem ganhando espaço.

Hoje existem vários softwares no mercado para desenvolvimento de 

animações 2D e 3D.

Neste curso iremos utilizar o software Macromedia Flash que permi-

te desde a criação de animações interativas até as mais complexas 

utilizando a linguagem de programação denominada ActionScript.

1.1 Noções sobre técnicas de animação
Veja abaixo mais sobre estas técnicas.

1.1.2 Animação Tradicional, animação por célula 
ou animação desenhada à mão:

Quando falamos neste tipo de animação deve vir a sua mente os desenhos 

animados como os dos estúdios Walt Disney,Hannah-Barbera, entre outros. 

Este tipo de animação é feita frame a frame (quadro a quadro), onde cada 

quadro é representado por uma pintura feita à mão, é bastante complexa, 

apesar de atualmente possuir diversas etapas já automatizadas por computa-

dor, este tipo de animação exige o envolvimento de equipes bastante grandes 

para conclusão de um projeto.

e-Tec BrasilAnimação para web 13



http://desenhoeanimacao.com.br/tecnica/flip-book/

1.1.3 Cel Animation 

Nesta técnica cada personagem é desenhado em uma folha separada de 

papel opaco. Depois, no momento de criar a animação, os diferentes perso-

nagens são sobrepostos em cima do plano de fundo em cada frame(quadro. 

Neste processo os desenhistas não têm que desenhar o frame completo, 

apenas as partes relativas a um personagem individual.

http://www.youtube.com/watch?v=QLRB0S2d0rg

1.1.4 Rotoscoping

É uma técnica onde as imagens são copiadas de um vídeo para uma animação.

O animador desenha o movimento e a forma do objeto referindo a partir do 

vídeo, em vez de o imaginar. Com esta ajuda do rotoscoping pode-se animar 

cenas complexas que de outra forma seriam difíceis de visualizar. A desvan-

tagem desta técnica consiste na adequação do vídeo certo para a cena que 

se pretende animar.

Técnico em Informática para Internete-Tec Brasil 14



http://www.youtube.com/watch?v=z32h-b9-8Qw

1.2 Animação por Computador

Com o passar do tempo os desenhistas ficaram cada vez mais dependentes 

do computador e o processo de criação da animação ficou mais rápido. 

Existem três categorias básicas de animação por computador: keyframing, 

motion capture e simulação.

1.2.1 Keyframing

Este termo está associado ao processo de criação de animação à mão por 

meio de desenho. Nesta técnica é criado um storyboard e depois os dese-

nhistas desenham os principais frames(quadros) da animação. O computa-

dor faz interpolação dentro destes frames, o algoritmo de interpolação é um 

fator importante para a aparência final da ação. A forma mais simples de 

interpolação é a interpolação linear. Esta interpolação resulta em um movi-

mento de aspecto um pouco instável, isto porque as velocidades dos objetos 

em movimento são descontínuas. Para corrigir este problema, outras técni-

cas de interpolação são usadas para produzir curvas interpoladas suaves. O 

resultado deste tipo de animação é o objeto em um ponto inicial se move 

até o ponto final. Embora os computadores possam reduzir o trabalho atra-

vés da interpolação a especificação manual do movimento requer talento e 

treino.

O Flash trabalha com este tipo de interpolação, veremos como funciona 

mais a frente.

e-Tec BrasilAnimação para web 15



http://www.izware.com/mirai/animation.htm

1.2.2 Motion Capture 

Esse tipo de animação consiste em uma câmera que captura movimentos 

e cria uma representação codificando os movimentos para o computador. 

Esta técnica utiliza sensores especiais designados por trackers. Estes trackers 
registram o movimento de um ser humano. Os dados gravados são depois 

usados para gerar a animação.

sitemaker.umich.edu                                             

katherine89taylor.wordpress.com
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1.2.3 Simulação

Esta técnica de animação utiliza as leis da física para gerar o movimento de 

figuras e outros objetos. São desenhados seres humanos, animais e outros 

seres virtuais e seu conjunto corporal, depois disso, eles serão animados atra-

vés de equações de movimento derivadas de leis físicas existentes na biblio-

teca do software utilizado para este fim. Este software calcula e aplica ações 

a cada junção do corpo simulado para fazer com que o personagem execute 

uma determinada ação através de algoritmos pré definidos.

escultopintura.com.br

1.3 ANIMAÇÃO PARA WEB

Ao abrir um site você certamente já se deparou com inúmeras animações. 

Os Web designers utilizam esta técnica para chamar “atenção” por toda a 

Internet. Os tipos de animação mais comuns encontrados na Web são:GIFs 

animados, HTML dinâmico, Java, Flash e Shockwave.

Você deve estar se perguntando, qual a diferença entre eles? Com qual des-

tes tipos vou trabalhar?

Vamos ver um pouco mais sobre GiFs animados, Flash e Shockwave.

1.3.1 GIFS ANIMADOS

Os Gifs animados são criados por uma série de poses de uma imagem mos-

trada em seqüência. Estes tipos de animação foram as primeiras utilizadas na 

Internet, sendo muito populares ainda hoje. Muitos softwares são utilizados 

para criação deste tipo de arquivo.

e-Tec BrasilAnimação para web 17



diaadia.pr.gov.br

1.3.2 FLASH E SHOCKWAVE

As animações em Flash e Shockwave aparecem atualmente como parte das 

páginas Web e incluem um alto nível de interatividade. Os aplicativos de 

visualização do Shockwave não apenas exibem as animações, mas também 

reconhecem a interação do usuário e controlam como o browser vai respon-

der, este tipo de animação vem cativando mais os usuários do que qualquer 

outro formato semelhante. O Flash, em particular, tem tido sucesso porque 

vem agregado com a maioria dos browsers e pode transmitir animações com 

maior rapidez.

Os aplicativos Flash e Shockwave são produzidos pela mesma empresa, po-

rém, existem algumas diferenças significativas entre eles.

O aplicativo utilizado para criação dos arquivos Shockwave é o Director.  Este 

aplicativo foi criado para produzir animações interativas ainda da época do 

CD-Rom, antes da Internet tomar o rumo de hoje, porém este tipo de ani-

mação ainda é muito utilizado.

Já o Flash foi construído integralmente para ser usado na Web, todo o po-

tencial deste aplicativo é voltado para esta área.

Os arquivos em Flash carregam mais rapidamente que arquivos Shockwave, 

porém o Shockwave é mais versátil, podendo ser utilizado para criação de 

jogos mais complexos.

Técnico em Informática para Internete-Tec Brasil 18



Interface Director

gamedev.net

Interface Flash

softwareinreview.com
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Aula 2 – Tipos de imagem e Sistema de Cores 

2.1 TIPOS DE IMAGEM

As imagens digitais podem ser divididas em dois grupos: 

• Bitmaps: Preenchem cada pixel para formar uma figura.  

• Vetoriais: As figuras são geradas matematicamente através de fórmulas e 

têm como característica a capacidade de serem apagadas ou redimensiona-

das sem perder resolução.

2.1.1 BITMAPS

Este tipo de imagem é dividido nos pontos de uma matriz. Cada ponto é 

gravado com seu valor particular de luminosidade e cor formando um mapa 

(map) dos pontos (bit). Mesmo as áreas sem desenho (fundo) fazem parte do 

arquivo. Quando este tipo de imagem é alterado, como no caso de aumento 

do tamanho, ocorre perda de resolução e qualidade.

forums.tibiabr.com

2.1.2 VETORIAL

A palavra vetorial vem de vetor que se refere a uma linha, porém, a represen-

tação vetorial descreve um desenho como uma série de linhas e formas. Pos-

sui algumas regiões preenchidas com cor sólida ou sombreada. Uma imagem 

vetorial possui uma série de pontos em torno do desenho que podem ser 

modificados livremente sem que a figura perca suas características iniciais.

e-Tec BrasilAnimação para web 21



wiki.dcc.ufba.br

2.2 PRINCIPAIS TIPOS DE FORMATO DE IMAGENS 
BITMAP

• TIF: é maior em tamanho e melhor em qualidade de imagem. É o formato 

ideal para o tratamento de imagem antes de ser convertida para qualquer 

formato. Não perde resolução quando o tamanho original da imagem é al-

terado. 

• BMP: é o formato mais comum. Todos os programas gráficos, tanto os 

mais simples quanto os profissionais conseguem abrir e ler este formato. 

• GIF: formato especial para trabalhar na Web. São arquivos que ocupam um 

pequeno espaço no computador, sendo perfeitos para o desenvolvimento de 

páginas para Internet. 

• JPG: formato especial para trabalhar na Web. Tem como desvantagem 

perder muito a qualidade da imagem quando alterado o seu tamanho ori-

ginal. São arquivos que ocupam um pequeno espaço e são perfeitos para o 

desenvolvimento de páginas para Internet.
2.3. SISTEMAS DE CORES

2.3.1 RGB
RGB é a abreviatura do sistema de cores aditivas formado por Vermelho 

(Red), Verde (Green) e Azul (Blue). O sistema RGB reproduz cores em dis-

positivos eletrônicos como monitores de TV e computador, “datashows”, 

scanners e câmeras digitais, assim como na fotografia tradicional.

Técnico em Informática para Internete-Tec Brasil 22



http://pt.wikipedia.org/wiki/Ficheiro:Synthese%2B.
svg

2.3.2 CMYK
CMYK é a abreviatura do sistema de cores formado por Ciano (Cyan), Ma-

genta (Magenta), Amarelo (Yellow) e Preto (Key).

O CMYK funciona devido à absorção de luz, pelo fato de que as cores que 

são vistas vêm da parte da luz que não é absorvida. Este sistema é utilizado 

em  impressoras e fotocopiadoras para reproduzir a maioria das cores do 

espectro visível, e é conhecido como quadricromia. É o sistema subtrativo de 

cores, em contraposição ao sistema aditivo, o RGB.

http://pt.wikipedia.org/wiki/Ficheiro:SubtractiveColorMixing.png
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Aula 3 – Uma Visão geral do Flash

SOBRE O FLASH

Segundo a enciclopédia livre Wikipédia o Adobe Flash (antes: Macromedia 
Flash), ou simplesmente Flash, é um software primariamente de gráfico ve-

torial - apesar de suportar imagens bitmap e vídeos - utilizado geralmente 

para a criação de animações interativas que funcionam embutidas em um 

navegador web. O produto era desenvolvido e comercializado pela Macro-
media, empresa especializada em desenvolver programas que auxiliam o 

processo de criação de páginas web.

Costuma-se chamar apenas de flash os arquivos gerados pelo Adobe Flash, 
ou seja, a animação em si. Esses arquivos são de extensão “.swf” (de Sho-

ckwave Flash File). Eles podem ser visualizados em uma página web usando 

um navegador que o suporta (geralmente com plug-in especial) ou através 

do Flash Player, que é um leve aplicativo “somente leitura” distribuído gra-

tuitamente pela Adobe. Os arquivos feitos em Flash são comumente utili-

zados para propaganda animada (banners) em páginas web, mas evidente-

mente não limitando-se a isso, pois existem diversos jogos e apresentações 

dos mais variados tipos utilizando a tecnologia. Até mesmo sites inteiros 

podem ser feitos em ‘.swf’.
3.1 QUAL VERSÃO UTILIZAR?
Se você procurar na Web irá encontrar várias versões do Adobe Flash, porém 

optamos utilizar o Adobe Flash CS3 Portable que você poderá acessar dire-

tamente sem instalação até mesmo através do pendrive.

O Flash CS3 é uma ferramenta profissional para criação de animações no 

formato ‘.swf’, extensão padrão do Flash e amplamente encontrada na In-

ternet. Os recursos criados através deste software podem ser utilizados para 

desenvolver páginas mais chamativas e inovadoras.

O programa oferece ferramentas avançadas e sofisticadas de vídeo, tudo 

para que o trabalho final fique perfeito e com extrema qualidade. Adobe 
Flash CS3 possui suporte com os demais programas da Adobe, como o Pho-
toshop e o Illustrator. Assim, você pode trabalhar em conjunto desenvolven-
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do o conteúdo interativo para sites. Com uma interface cuidadosamente 

desenvolvida, todas as funções do programa encontram-se bem localizadas, 

facilitando o acesso e identificação de todas as opções do programa.

3.1.2 FICHA TÉCNICA DO SOFTWARE...

Software: Adobe Flash CS3 Portátil

Estilo : Animações, Imagens em Flash

Fabricante : Adobe

Ano : 2008

Sistema Operacional : XP, Vista

Tamanho : 97 mb

Idioma : Inglês

3.1.3 Requisitos do Windows

• Processador Intel® Pentium® 4, Intel Centrino®, Intel Xeon® ou Intel 

Core™ Duo (ou compatível)

• Microsoft® Windows XP com Service Pack 2 ou Windows Vista™ Home 

Premium, Business, Ultimate, ou Enterprise 

• 512MB de RAM 

• 2,5GB de espaço disponível em disco rígido 

• Resolução de monitor de 1.024 x 768 com placa de vídeo de 16 bits

• Software QuickTtime 7.1.2 (necessário para os recursos multimídia)

• Software DirectX 9.0

Técnico em Informática para Internete-Tec Brasil 26



3.2 O MUNDO DE TRABALHO DO FLASH...

3.2.1 INTERFACE GRAFICA

Quando você executar o ADOBE FLASH CS3 PORTABLE a seguinte tela será aberta:

A tela de entrada é exibida com 3 divisões, são elas: 

• Open a Recent Item: Exibe os arquivos manipulados anteriormente, você 

poderá clicar em um dos nomes para volta a manipular o arquivo.

• Create New: Utilize para criar um novo documento.

• Create from Template: Contem arquivos prontos do Flash.

• Extend: Utilizado para instalar recursos adicionais do software.

Para iniciar um novo documento iremos clicar na opção Flash File (ActionS-
cript 3.0).
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Agora podemos visualizar a INTERFACE GRAFICA ou GRAPHICAL USER IN-
TERFACE (GUI) do Flash é totalmente personalizável. Sendo assim é comum 

um ambiente de trabalho diferente do padrão do Flash.

1 – PAINEL DAS FERRAMENTAS
O painel das Ferramentas contém todas as ferramentas que serão necessá-

rias para criar as animações. Sua disposição pode ser alterada clicando no 

canto superior esquerdo.
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As duas disposições apresentam o mesmo número de ferramentas, e são 

úteis por uma questão de espaço.

2 – Painel das camadas (LAYERS) e linha 
do tempo (TIMELINE)
Este painel é redimensionável, uma vez que é possível ter várias layers em 

um projeto. 

Para redimensionar este painel, clique e arraste na barra de divisão deste painel.

Para ocultar este painel clique na opção Hide Timeline, caso necessite de es-

paço.
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3 – ÁREA DE PAINÉIS OPCIONAIS
Nesta área poderemos exibir qualquer painel que se encontra no menu Window. 

Na disposição Default, que é a que temos de momento, teremos os painéis Color 
e Swatches (num único painel) e a Library. Você pode minimizá-los se quiser.

Você também pode ocultar os painéis clicando em >>.
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Podemos escolher quais painéis queremos utilizar no menu WINDOW.

Você pode acrescentar ou tirar os painéis como desejar. Os painéis vão se 

juntando nas guias e podem ser minimizados ou ocultados.

4 – ÁREA DE TRABALHO, STAGE (PALCO)
A Área de Trabalho fica no centro da Interface Gráfica (GUI) e será sempre 

quadrangular, suas propriedades com dimensão, cor de fundo e velocidade 

podem ser alteradas no painel de Propriedades (Properties).
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• Size: altera o tamanho do projeto.

• Publish: para escolher o formato da publicação.

• Background: plano de fundo do projeto.

• Frame rate: Frames Per Second (fps), ou seja, a velocidade com que o nosso

filme será processado.

Sobre “fps”...

O Flash segue o mesmo principio da animação tradicional, em que se dese-

nha em folhas separadas os movimentos que se pretende de um objeto e ao 

passar as folhas em velocidade acelerada obtemos uma animação. No Flash 

as folhas são chamadas de FRAME (quadro), os FRAMES encontram-se na 

Timeline.

Cada LAYER (camada) contem vários FRAMES, que são estes quadradinhos 

que vocês podem ver acima. O primeiro FRAME está com uma “bolinha” 

que indica o ponto inicial de nossa animação dentro do LAYER 1.

A velocidade 

“fps” para a web 

deverá encontrar-

-se dentro do in-

tervalo 12 – 20, 

com 24 estamos 

muito próximo do 

vídeo, já em jogos, 

poderá ser coloca-

do com 30 fps.

5 – PAINEL PROPERTIES, FILTERS E PARA-
METERS
A primeira guia deste painel é a de propriedades ou seja PROPERTIES. Esta 

guia exibe todas as propriedades de um determinado objeto e mudará assim 

que o próximo objeto for selecionado. Neste caso, como só temos um pro-

jeto em branco, ela exibe as propriedades deste projeto.

Se clicarmos na ferramenta Pencil, veja o que acontece.
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A segunda guia deste painel é a guia de filtros ou seja FILTERS. Ela contém 

filtros idênticos aos do Adobe Photoshop e Fireworks. Estes filtros poderão 

ser aplicados em objetos específicos. A lista inclui filtros como o Drop Sha-
dow para criar sombras, o Glow para dar brilho entre outros.

Somente após a seleção de um objeto os filtros são ativados.

Guia Filters sem seleção de objeto

Guia Filters após seleção de objeto

A terceira e última guia é a guia de parâmetros, ou seja, guia Parameters. 
Como o próprio nome diz ela parametriza os componentes do Flash. Estes 

componentes estão divididos por Vídeo, Media, Data e User Interface e serão 

abordados mais para frente.

Se você modificou 

a GUIA, para vol-

tar na disposição 

padrão do Flash 

vá até o painel de 

menus e escolha 

WINDOWN, em 

seguida WORKS-

PACE e por último 

DEFAULT.

Antes de abordar 

as diversas áreas 

do GUI, vamos 

colocá-lo com a 

disposição padrão 

da Adobe.
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Aula 4 - Conhecendo ferramentas e 
propriedades

4.1 TRABALHANDO NO PALCO

4.1.1 Grid (Grade)
Conjunto de linhas verticais e horizontais que se interseccionam no palco, a 

fim de alinhar, redimensionar e posicionar objetos com precisão.

Para visualizar e configurar o Grid, clique menu View, aponte para Grid e em 

seguida para Show Grid.

Se desejar editar o Grid, clique menu View, aponte para Grid e em seguida 

para Edit Grid. Você poderá definir a cor do Grid, alterar a quantidade de es-

paço entre as linhas do Grid (verticalmente e/ou horizontalmente). Quando 

terminar clique em OK e as grades aparecerão no palco.

4.1.2 Rules (Réguas)
As réguas são utilizadas para indicar a posição dos objetos no palco e 

suas dimensões.

Para visualizar as réguas Clique no menu View, em seguida escolha Rules. 
Serão exibidas uma régua horizontal e outra vertical
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Trocando a unidade de medida da Régua
Clique em Modify > Document. 

No item Ruler units (unidades de régua), defina a unidade de medida dese-

jada e pressione o botão OK.

4.1.3 Guides (Guias)
As guias possuem o mesmo objetivo da Grade: posicionar objetos. A diferen-

ça é a de que você pode posicionar as guias em qualquer ponto no palco e 

pode inserir quantas guias forem necessárias.

Para inserir guias ative a visualização da régua, caso não esteja (View > Rulers).

Técnico em Informática para Internete-Tec Brasil 36



Depois basta posicionar o ponteiro do mouse sobre uma das réguas, clicar e 

arrastar a guia até o local desejado. Você pode repetir o processo e colocar 

quantas guias quiser.

4.1.4 Configurando Guias
Clique no menu View, aponte para Guides e no submenu clique em Edit 
Guides.

Na caixa de diálogo você pode definir a cor da guia, exibir ou ocultar as 

Guias do palco ou ainda bloquear guias (Lock Guides), as guias ficam impos-

sibilitadas de serem movidas.

Se quiser apagar todas as guias clique no botão Clear All.

Algumas destas opções você também pode acessar pelo menu View > Guides.

as guias e as 

grades, não apa-

recem quando 

seu arquivo é ex-

portado. Elas são 

visíveis apenas 

no ambiente de 

autoria.

4.2 DESVENDANDO O PAINEL DAS FER-
RAMENTAS
As ferramentas de desenho do Flash utilizam o sistema de criação de ima-

gens vetoriais, que são equações matemáticas que seu computador traduz e 

exibe como objetos desenhados como vimos anteriormente.

Para entender melhor o painel de ferramentas, vamos dividi-lo em partes.

Nota: as guias e as grades, não aparecem quando seu arquivo é exportado. 

Elas são visíveis apenas no ambiente de autoria.
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Ferramentas de Seleção

Ferramentas de Desenho e Pintura

Ferramentas de Preenchimento

Ferramentas para Visualização

Ferramentas de Cores

Ferramentas para Modificação

4.2.1 Descrevendo as ferramentas

Todas as ferramentas 

podem ser acessadas 

clicando nas mesmas 

ou pela(s) tecla(s) 

correspondente(s) 

descrita(s) acima.
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4.2.2 Ferramentas de Seleção
Selection: permite selecionar, arrastar ou modificar os objetos clicando na 

borda do mesmo.

Free Transform: permite dimensionar ou rotacionar um objeto.

Subselection: edita os pontos de um objeto.

Lasso: seleciona parte de um ou mais objetos, basta clicar e arrastar sobre a 

tela.

4.2.3 Ferramentas de Desenho e Pintura
Pen: serve para desenhar objetos de formas irregulares ou não. 

Selecione a ferramenta Caneta, vá até o palco e dê um clique com o mouse. 

Mova o cursor para um outro local e dê mais um clique. Surgirá uma linha 

reta entre estes dois pontos. Continue a operação até encerrar o desenho. 

Se quiser fechar o desenho, clique novamente no ponto inicial da linha. 

Aparecerá junto ao cursor do mouse um pequeno círculo, indicando que 

você irá fechar o desenho. Se não quiser fechá-lo, dê um duplo clique para 

finalizar a linha.
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Você pode adicionar, remover ou converter pontos clicando nas opções da 

ferramenta Pen e depois em cima das linhas.

Line: Utilizada para desenhar linhas retas. Para limitar esta ferramenta a de-

senhar linhas com ângulo reto e de 45º, pressione a tecla Shift antes de 

desenhar. Você pode juntar uma linha com outra inserindo uma nova linha 

e clicando nas extremidades

Pencil: Serve para desenhar a mão livre. Selecione a ferramenta, segure o 

botão do mouse pressionado e comece a desenhar. Se pressionar Shift, de-

senhará linhas de ângulo reto (horizontal e vertical). 

A ferramenta Pencil possui modificadores no canto inferior direito do 

painel. São elas:

•	 Straighten: Permite endireitar as linhas que você traça. Se desenhar 

uma linha “tremida” este modificador a endireitará para você.

•	 Smooth: Permite suavizar as linhas que você desenha;

•	 Ink: A linha ficará conforme você a desenha, fazendo apenas uma 

leve suavização.
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Text: permite inserir um texto no palco. Basta clica no palco e digitar o texto. Você 

pode alterar a fonte, tamanho, cor e outras propriedades na barra de propriedades.

Rectangle: Desenha elipses, retângulos e polígonos. Para desenhar, selecione 

a ferramenta, vá até o palco, segure e arraste.

Brush: Esta ferramenta é utilizada para pintar áreas do palco como se estives-

se realmente usando um pincel. Selecione-a e arraste para começar a pintar. 

Pressionando Shift, você pintará linhas com ângulos retos.

Esta ferramenta possui os seguintes modificadores:

Tipo do Pincel: Determina o comportamento do pincel em relação aos objetos 

que estão no palco. Se o traço vai ficar na frente, atrás ou dentro do objeto.

Tamanho do Pincel: Determina o tamanho do pincel.
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Formato do pincel: Escolha um entre os diversos formatos de pincel.

4.2.4 Ferramentas de Preenchimento
Ink Bottle: Utilizada para pintar o contorno de um objeto. Basta escolher a 

cor na paleta de propriedades e clicar sobre o contorno do objeto ou linha 

que deseja pintar.

Eyedropper: Também conhecido como “Conta Gotas”. Esta ferramenta é 

utilizada para obter a cor de um determinado local e passá-la para um obje-

to. Basta clicar na cor desejada e depois preencher o objeto.

Exemplo: Quero preencher o objeto abaixo com a cor verde do slogan do 

Google. É só clicar com o Eyedropper na cor verde e depois preencher o 

objeto com a cor obtida.

Você pode copiar e co-

lar uma figura no Flash. 

Porem para conseguir 

obter a cor da mesma 

com o Conta Gotas, 

você deve manter a fi-

gura seleciona e clicar 

no menu Modify >> 

Break Apart (Control 

B). Desta forma você 

“quebra a imagem”.
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Paint Bucket: Utilizada para preencher um objeto. Basta escolher a cor na 

paleta de propriedades e pintar o objeto desejado clicando sobre ele. Mas 

atenção, para que isso aconteça o objeto deve estar fechado.

Eraser: Utilizada para apagar determinadas áreas dos objetos desenhados. 

Esta ferramenta possui os seguintes modificadores:

Tipo de Borracha: Escolha o tipo de borracha que deseja utilizar conforme 

sua necessidade. Você poderá apagar todo o objeto, apagar preenchimen-

tos, apagar linhas ou apagar preenchimentos selecionados com as ferramen-

tas seta ou laço.

Torneira: esta ferramenta que tem a aparência de uma torneira apaga todo 

o preenchimento ou contorno que for clicado.

Formato da Borracha:escolha o formato e o tamanho da borracha desejado.

4.2.5 Ferramentas para Visualização
Hand: serve para movimentar o palco. Basta clicar e arrastar no palco.

Zoom: aumenta ou diminui o Zoom no palco. Selecione abaixo da paleta 

Aumentar ou Diminuir Zoom e clique no palco.

4.2.6 Ferramentas de Cores
Stroke Color: paleta de cores da linha. Com um objeto seleciona escolha 

uma cor para linha.
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Fill Color: paleta de cores de preenchimento. Com um objeto seleciona esco-

lha uma cor para preenchimento.

Black and White: aplica a cor da linha preta e preenchimento branco.

Swap Colors: alterna a cor da linha com a do preenchimento e vice versa.

4.2.7 Ferramentas para Modificação
Snap to Objects: os objetos desenhados são “atraídos” quando você os 

move ou dimensiona.

Smooth: permite suavizar linhas e formas simples.

Straighten: permite endireitar linhas e formas simples.
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Aula 5 - Trabalhando com Objetos

5 SELECIONANDO OBJETOS

5.1 Linhas e Preenchimentos
Para selecionar uma linha, um preenchimento ou um símbolo com a fer-

ramenta Selection, clique nele uma vez. Observe que a seleção do preen-

chimento e da linha é feita de forma separada. Para selecionar a linha e 

o preenchimento de um objeto simultaneamente, dê um duplo clique no 

preenchimento. Para selecionar linhas de um objeto fechado, dê um duplo 

clique sobre a linha.

5.2 Selecionar vários objetos
Com a Ferramenta Selection

Pressione a tecla Shift e vá clicando nos objetos desejados. Se quiser selecio-

nar todos os objetos do palco, clique no menu Edit > Select All.

Você pode selecionar objetos arrastando o mouse sobre eles, criando assim 

uma caixa de seleção. Os objetos que estiverem dentro desta caixa serão 

selecionados.

Com a Ferramenta Lasso (laço)
Com esta ferramenta você seleciona áreas não uniformes dentro de uma forma.

Para selecionar com a ferramenta Lasso segure o botão pressionado e selecione 

uma área qualquer dentro do palco. Quando soltar o botão, a área estará selecio-

nada. Se pressionar Shift, você fará novas seleções sem desmarcar as anteriores.
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5.3 Alterando as características da Linha 
e Preenchimento

5.3.1 Preenchimento
No Flash trabalhamos com linhas e contornos. Uma linha é somente uma 

linha, mas um contorno é uma linha sem começo ou fim. Embora linhas e 

contornos referenciam essencialmente a mesma coisa, você deve entender a 

distinção acima para trabalhar com eles no Flash.

5.3.2 Para alterar as características de uma linha ...

Selecione a linha ou contorno desejado. Na barra Propriedades aparecem 

as opções de configuração da linha.Defina o estilo da linha, sua espessura e 

cor. As configurações são refletidas diretamente sobre a linha selecionada. 

Clique no Botão CUSTOM ao lado do tipo da linha para personalizar a mesma.
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5.4 Trabalhando com Preenchimentos...
Podemos aplicar diversos tipos de preenchimentos em um objeto: sólido (cor 

uniforme), gradiente ou ainda um preenchimento com mapa de bits.

Stroke Color (cor da linha)

Fill Color (cor do preenchimento)

Para modificar o tipo de preenchimento utilize o Painel Suspenso Color do 

lado superior esquerdo.

•	 Para preencher com cor sólida: Selecione o objeto que deseja pintar, cli-

que sobre a ferramenta Fill Color, na paleta cores, clique sobre o botão 

cor de preenchimento e selecione a cor desejada.

•	 Para preencher com gradiente: Selecione o objeto que deseja pintar, em 

seguida escolha no Painel Suspenso Color o tipo de preenchimento em 

Type, você poderá escolher: Linear ou Radial.
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Serão abertos algumas propriedades que você poderá modificar confor-

me seu gosto.

Valores da cor escolhida

Arraste os pontos 
para personalizar 
o gradiente

Preenchimento do gradiente

Clique e arraste o mou-
se sobre a paleta de co-
res para obter uma cor

Modifique o tom da cor

Para acrescentar mais 
pontos ao gradiente cli-
que 2 vezes entre os pon-
tos. Para retirar o ponto 
criado clique sobre ele e 
arraste-o para baixo de-
pois solte.

•	 Para preencher com um Bitmap: Selecione o objeto que deseja pintar, em 

seguida escolha no Painel Suspenso Color o tipo de preenchimento em 

Type: Bitmap. Serão exibidas as pastas de seu computador. Você deverá 

escolher um arquivo tipo Bitmap para preencher o objeto.

Para desenhar de forma 
mais fácil é necessária uma 
mesa digitalizadora, que 
consiste em uma mesa 
mais um apontador sem 
fio, podendo ser uma cane-
ta ou qualquer ferramenta 
que forneça uma ponta ou 
um mouse. Dependendo 
do modelo, a caneta in-
clui uma borracha virtual 
na extremidade oposta à 
da ponta. Na superfície da 
mesa, na margem superior 
da área de trabalho, os bo-
tões servem para funções 
como copiar, colar, salvar ...
Ela permite que o usuá-
rio, ao tocar a mesa com 
o apontador, informe ao 
computador a coordena-
da deste ponto dentro da 
mesa, controlando todas 
as formas e linhas, permi-
tindo desenhar imagens 
diretamente no computa-
dor, geralmente através de 
um Software de tratamen-
to de imagem, dando a 
oportunidade de controlar 
o curso do mesmo modo 
como numa folha de papel 
com uma caneta qualquer.



5.5 Trabalhando com Objetos...

5.5.1 Movendo objetos

•	 Através da Ferramenta Selection: Clique na ferramenta Selection e sele-

cione o(s) objeto(s) desejado(s). Segure o botão esquerdo do mouse pres-

sionado e arraste. Você também pode selecionar um objeto e pressionar 

as teclas de seta para movê-lo para cima, para baixo, para a esquerda e 

para a direita um pixel por vez. Se mantiver pressionada a tecla Shift en-

quanto pressiona um tecla de seta, seu objeto move-se 10 pixels por vez.

•	 Posicionar um objeto com precisão: Selecione o objeto, na Barra Proprie-

dades, altere o valor do eixo X para mover o objeto para a esquerda ou 

para a direita e o valor de Y para mover o objeto para cima ou para baixo. 

Se digitar valores negativos você posicionará o objeto para fora do palco.

Eixos X e Y

O Flash considera as coorde-
nadas x e y começando do 
canto superior esquerdo do 
Palco. A coordenada x au-
menta quando você se des-
loca para a direita. A coor-
denada y aumenta quando 
você se desloca para baixo. 
Neste caso, podemos consi-
derar que “0,0” está no can-
to superior esquerdo.

5.5.2 Redimensionar objetos

•	 Através da Ferramenta Free Transform: Selecione o objeto e em seguida cli-

que na ferramenta Free Transform, as alças de redimensionamento(pequenos 

quadrinhos pretos) aparecerão ao redor do objeto, clique e arraste para fora 

para aumentar o objeto ou para dentro para reduzir seu tamanho. Para rota-

cionar clique com o mouse sobre os quadradinhos dos lados externos.

Dimensionar Rotacionar
Se arrastar uma das alças dos 
cantos, você irá dimensionar 
o objeto  proporcionalmente. 
Se arrastar uma das alças la-
terais, irá deformar o objeto. 
Outra maneira de redimen-
sionar um objeto é utilizando 
o menu Modify > Transform e 
escolha uma das opções.

•	 Redimensionar com precisão: Selecione o objeto, na Barra Propriedades, 

altere o valor de W (width – largura ) e H (heigth – altura).

W (width – largura )
H (heigth – altura)
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5.5.3 Agrupar objetos

• Como agrupar objetos: Selecione os objetos que farão parte do grupo, 

no menu Modify, clique em Group (Ctrl + G), desta forma os objetos serão 

agrupados.

• Como desagrupar objetos: Selecione o grupo de objetos, no menu Modify, cli-

que em Ungroup (Ctrl + Shift+ G), desta forma os objetos serão desagrupados.

5.5.4 Alinhar Objetos

•	 Para alinhar objetos pelo Painel Suspenso Align: Selecione os objetos que 
quer alinhar, clique nas opções do painel suspenso align.

Align:    
Alinhar borda esquerda 
Alinhar centro horizontalmente
Alinhar borda direita 

Alinhar margem superior
Alinhar centro verticalmente 
Alinhar margem inferior

Distribute:
Distribuir margem superior 
Distribuir centro verticalmente 
Distribuir margem inferior 

Distribuir margem esquerda
Distribuir centro horizontal-
mente 
Distribuir margem direita 

To stage: Alinhar/Distri-
buir no palco: Ativado fará 
com que a posição do(s) 
objeto(s) selecionado(s) 
seja alterada em relação 
ao Palco.

Space: 
Espaço Uniforme Vertical
Espaço Uniforme Horizontal

Match Size:
Ajustar largura: todos os objetos se-
lecionados ficam com a mesma lar-
gura do maior objeto selecionado;
Ajustar altura: todos os objetos se-
lecionados ficam com a mesma al-
tura do maior objeto selecionado;
Ajustar largura e altura: Produz o 
efeito das duas ferramentas acima 
ao mesmo tempo;

Se você quer que um ob-
jeto fique posicionado 
exatamente no centro 
do palco, simplesmente 
ative o botão Alinhar/
Distribuir no palco e cli-
que sobre os botões Ali-
nhar centro horizontal-
mente e Alinhar centro 
verticalmente. O objeto 
se encontrará no meio 
do palco.
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•	 Para alinhar objetos pelo Menu Modify: Selecione os objetos que quer ali-

nhar, clique no Menu Modify > Align e escolha uma das opções do menu.

Objetos bem alinhados e 
distribuídos corretamen-
te dão uma aparência 
profissional à sua página. 
Acostume-se a utilizar 
esta ferramenta ao invés 
de tentar alinhar “à olho” 
os objetos no palco.

5.5.5 Segmentar e Conectar objetos

•	 Segmentar objetos: Segmentar uma forma significa cortar parte dela. É 

como se você tivesse em mãos uma tesoura e cortasse um pedaço de 

uma folha de papel. 

•	 Atividade de Aprendizagem: Desenhe no palco dois objetos de preenchi-

mento diferentes, depois arraste o primeiro objeto para dentro do segun-

do, clique no palco para tirar a seleção do objeto, agora retire o objeto do 

meio do outro, isso fará um “furo” no segundo objeto, mostrando a cor 

do fundo do palco. 

•	 Conectar objetos: A conexão consiste em combinar duas formas ou mais 

a fim de criar uma única unidade. Para realizar a conexão, as formas de-

verão possuir a mesma cor (com preenchimentos sólidos). Objetos agru-

pados não funcionam, os objetos não podem ter contornos.

Atividade de Aprendizagem: Desenhe no palco dois objetos de preenchimento 

iguais e sem contorno (apague o contorno clicando no mesmo e apertando a te-

cla DELETE), coloque um objeto sobre o outro e clique no palco para retirar a se-

leção do objeto. Agora você tem um objeto produzido a partir de duas formas.

5.5.6 Duplicar objetos
•	 Duplicando objetos: Para duplicar objeto(s) basta selecioná-los, em se-

guida aperte Control + D, ou clique no menu Edit > Duplicate.

Desenhe um quadrado 
no palco com preenchi-
mento e contorno, clique 
na  ferramenta Selection 
e posicione o cursor do 
mouse sobre a aresta 
(lado) do quadrado. Um 
pequeno ícone de curva 
aparecerá junto ao cursor 
do mouse, clique e arras-
te para fora, assim você 
estará criando uma for-
ma curva.
Você também pode modi-
ficar a forma clicando em 
um dos cantos do quadra-
do. Um pequeno ícone de 
canto surgirá junto ao 
cursor do mouse, clique e 
arraste para um novo lo-
cal. Desta forma você es-
tará deslocando um dos 
pontos do quadrado para 
um novo local.
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5.5.7 Deformar os objetos

É possível transformar os objetos originais como se você estivesse modelan-

do ou esculpindo os mesmos para lhes dar um novo formato por meio da 

ferramenta Selection.

Teste os métodos de de-
formação descritos aci-
ma com outras formas 
como círculos, linhas ou 
qualquer outro objeto.

5.5.8 Rotacionar objetos
Podemos girar um objeto de forma livre ou utilizando valores para um giro 

mais preciso.

Cada objeto possui um eixo central (eixo de rotação) e o giro se faz em 

torno deste eixo.
Desenhe um quadrado 
sem contorno e de ta-
manho médio no palco, 
selecione a forma dese-
nhada com a ferramenta 
Selection, em seguida, se-
lecione a ferramenta Free 
Transform, aparecerão 
modificadores em tor-
no do objeto, posicione 
o cursor sobre uma das 
alças e quando aparecer 
uma seta de círculo cli-
que e arraste no sentido 
horário ou antihorário. 
Para inclinar posicione o 
cursor na borda do obje-
to entre os modificadores 
e quando aparecer duas 
setinhas clique e arraste 
para esquerda ou direita.

Para rotacionar com precisão: Clique no Painel Suspenso Transform do 

lado direito do palco, aparecerão opções para rotacionar (Rotate) e inclinar 

(Skew), digite os valores que desejar.

5.5.9 Espelhando objetos
Espelhar objetos significa virá-los no sentido inverso, dando a sensação de 

uma imagem refletida em um espelho.

Selecione um objeto (você 
pode copiar e colar um Gif 
por exemplo), em seguida 
duplique o mesmo (con-
trol +D) e coloque um ao 
lado do outro, clique no 
menu Modify > Transform 
> Flip Horizontal
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Aula 6 - Trabalhando com textos no 
Flash

6 Trabalhando com Textos no Flash...

O Flash possui dois tipos básicos de texto: rótulo e bloco.

Um rótulo de texto consiste em um texto que é digitado sempre na mesma 

linha até que você pressione a tecla Enter para fazer a quebra de linha.

Já o bloco de texto consiste em uma área fixa onde seu texto irá se ajustar 

conforme as dimensões desta área.

6.1 Criando Rótulos de Texto
Prática1: Selecione a ferramenta Text, mova o cursor do mouse até o palco 

e clique no local onde quer inserir o texto. Aparecerá um cursor piscando 

dentro de uma pequena caixa, digite o texto e a caixa se expandirá.

6.2 Criando Blocos de Texto
Prática2: Selecione a ferramenta Text, vá até o palco, clique e arraste da es-

querda para a direita para definir a largura do bloco de texto, digite o texto 

desejado e o mesmo se ajustará automaticamente à largura da caixa.

6.3 Formatando Textos 
No Flash também é possível alterarmos a cor do texto, o tamanho, fonte, 

estilo e alinhamento. Depois de inserido o texto também é tratado como um 

objeto que se pode mover, rotacionar e redimensionar.

Atividade de Aprendizagem 1: Selecione o texto desejado com a ferramenta 

Selection, na barra Properties realize as alterações desejadas.
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6.4 Formatando parágrafos
Atividade de Aprendizagem 2: Digite um texto de bloco, selecione o texto, 

na Barra Properties escolha dentre uma das opções de alinhamento e, em 

seguida, clique no botão Opções de Formatação (veja acima). Surgirá a se-

guinte janela:

Recuo da 1º linha do parágrafo

Espaço entre as linhas

Margem Esquerda (recuo de texto)

Margem Direita (recuo de texto)

Altere as opções de formatação, clique no botão OK e confira o resultado.

6.5 Alterando a posição do texto
Atividade de Aprendizagem 3: Digite um texto rótulo ou bloco, selecione 

o texto, na Barra Properties clique no botão Alterar posição do texto (veja 

acima). Selecione uma das opções e verifique o resultado.

6.6 Dividindo o texto
Existem algumas configurações que não podem ser realizadas em um texto 

comum, preencher com gradiente, por exemplo, ou dar uma nova forma ao 

texto, como esticar uma letra. Para isso precisamos dividir o texto, ou seja, 

convertê-lo em uma imagem vetorial, como se o texto tivesse sido desenha-

do por você utilizando as ferramentas de desenho.
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Mas lembre-se: depois de dividir o texto você não poderá mais editá-lo. Cer-

tifique-se que o seu texto tem o conteúdo e a aparência desejada antes de 

dividi-lo. Selecione o texto desejado, 
modifique as fonte e demais 
configurações do texto na 
Barra Properties (estou uti-
lizando a fonte: Burnstown 
Dam), clique no menu Modify 
> Break Apart (Control + B), 
nesta primeira operação de 
Desmembrar apenas separa-
rá os caracteres, mas o texto 
continuará editável.

Com o texto deste jeito, você pode clicar em cada fonte e movê-las, forma-

tar cada uma delas separadamente, etc.

Mas para dividir o texto clique mais uma vez no menu Modify > Break Apart 
(Control + B), agora sim o seu texto estará dividido. Ao dividir o texto, é 

possível aplicar preenchimento gradiente a ele ou ainda deformá-lo como se 

fosse uma imagem vetorial qualquer.

Modifiquei a fonte do meu texto para: Baveuse e depois de dividi-lo apliquei 

um preenchimento gradiente através da ferramenta Fill (balde de tinta).

Você pode modificar o texto selecionando a ferramenta forma e editando os pontos.
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Aula 7 - Configurações de Som

7. Utilizando Som.
Utilizando sons você torna a navegação de sua página mais agradável e aju-

da a memorizar certos eventos que são atribuídos a um som. No flash existe 

uma representação gráfica composta de ondas, que variam em comprimen-

to (indicando tempo) e tamanho (indicando volume).

7.1 Importando sons
Antes de inserir um som a um quadro da linha do tempo ou a um botão, 

devemos primeiro importá-lo.

Clique no menu 

File > Import> 

Import to Library, 

selecione o arqui-

vo de som dese-

jado e clique no 

botão Abrir

Utilize arquivos .WAV ou  .MP3. Arquivos .MIDI não funcionarão.

O som selecionado será inserido na Biblioteca.

Após o som ser importado, deve-se decidir de que forma você irá utilizá-lo. 

Pode-se adicionar sons a um botão ou a um determinado quadro na linha do 

tempo e quando se atingir este quadro, o som será reproduzido.

Exiba a biblioteca clicando no menu Window > Library (Ctrl+L). 
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Clique com o 

botão direito 

do mouse sobre 

qualquer quadro 

que contenha o 

som, a Barra Pro-

perties exibirá as 

opções disponí-

veis para a confi-

guração do som.

7.2 Adicionando um som na linha do 
tempo
Atividade de Aprendizagem: Clique no som exibido na janela Library, arraste 

e solte-o no palco.

Devemos agora escolher até qual quadro o som irá tocar. Vá até a linha do 

tempo e clique no quadro 15. Aperte o botão F6 para criar um quadro chave.

7.3 Propriedades do som
O Flash possui um painel onde podemos realizar configurações que alteram 

o comportamento do som selecionado.

Sons disponíveis

Número de repetições

Sincronização do som

Edição personalizada
 do som

Número de repeti-
ções

Sound: escolha o som que quer alterar;
Effect: Selecione um efeito para o som. 
None: Não aplica nenhum efeito;
Left channel: O som é reproduzido somente no canal esquerdo;
Right channel: O som é reproduzido somente no canal direito;
Fade left to right(Fade esquerda para direita):Desloca o 
som de um canal para o outro;
Fade right to left (Fade direita para esquerda):Desloca o 
som de um canal para o outro;
Fade In: Aumenta gradualmente a amplitude de um som;
Fade Out: diminui gradualmente a amplitude de um som;
Custom: Esta opção abrirá uma janela para permitir 
uma configuração personalizada.

7.4 Configurar Som
Se as configurações pré-definidas não forem ideais para o seu som, você 

pode personalizá-lo.

Por exemplo, ajustar como ele deveria diminuir gradualmente o seu comprimen-

to ou seu volume. Essas configurações são realizadas clicando na opção Custom.
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Clique com o botão di-
reito do mouse sobre 
qualquer quadro que 
contenha o som, na 
Barra Properties, clique 
sobre o botão Edit (veja 
acima).
 Será aberta uma janela 
para configurar o som.

Selecione o efeito desejado

Controle de início e 
fim do som

Botões Play e Stop

Alças de envelope

Linha do tempo
do som

Opções da janela Edit Envelope:

•	 Effect: selecione um efeito pré-configurado para o som;

•	 Linha do tempo do som: exibe a duração de um som em segundos ou quadros.

•	 Controles de início e fim do som: você determina em que ponto o som 

começa a reproduzir e em qual ponto ele pára a reprodução. Isso encur-

tará o tempo de execução do som e reduzirá o tamanho do arquivo final 

do filme de Flash.

•	 Linhas e alças de envelope: determinam o volume do som no decorrer da 

reprodução. Clique em cima do som para que as linhas apareçam,

•	 Botões reproduzir/parar: utilize-os para testar os ajustes do som.

•	 Linha do tempo em segundos/quadros: permite escolher as unidades uti-

lizadas na linha do tempo. Os segundos são bons para ver a duração do 

seu som, já os quadros são bons para sincronizar o som com elementos 

visuais na tela.

Depois de configurar o som clique no botão OK. Para ouvir como ficou você 

deve publicar o trabalho. Agora vamos publicar em HTML aperte a tecla F12, 

nos próximos capítulos você aprenderá mais sobre publicação.

Quanto mais alta esti-
ver a alça mais alto será 
o volume. Você pode 
adicionar mais alças cli-
cando sobre um ponto 
da linha onde não te-
nha uma alça
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Aula 8 – Trabalhando com símbolos

8 Trabalhando com símbolos

Com símbolos podemos criar um único objeto e pode reutiliza-lo diversas 

vezes, sem afetar significativamente o tamanho do arquivo.

No Flash, podem ser criados três tipos de símbolos.

•	 Movie clips (Clipes de filmes): são filmes independentes, ou seja, pos-

suem sua própria linha do tempo, assim, se a linha do tempo principal 

parar, a linha do tempo do clipe de filme pode continuar reproduzindo.

•	 Buttons (Botões): Os botões são símbolos utilizados para que o usuário 

possa interagir com seu filme. São acrescentadas ações aos botões para 

que se possa controlar o filme de Flash.

•	 Graphics (Imagens gráficas): São imagens estáveis ou inanimadas que são 

utilizadas várias vezes em seu filme para compensar tamanho de arquivo.

8.1 Criando Símbolos
Sempre que você cria um símbolo ele é automaticamente adicionado à Bi-

blioteca. Pode-se criar um símbolo utilizando o conteúdo do palco ou criar 

um símbolo vazio que posteriormente você preenche com conteúdo.

8.1.1 Criando um símbolo a partir do conteúdo 
do palco:
Selecione os objetos que farão parte do símbolo, clique no menu Modify > 
Convert to Symbol, ou pressione a tecla F8, na caixa de diálogo que aparece 

defina um nome e um comportamento para o símbolo e pressione OK, o 

símbolo é automaticamente adicionado à Biblioteca.
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Quando um 

Novo símbolo é 

gerado. Um sinal 

de “+” no meio 

do palco indica o 

centro do novo 

Símbolo.

8.1.2 Criando um símbolo vazio
Inserty > New Symbol ou pressione Ctrl + F8, na caixa de diálogo que aparece, 

defina um nome e um comportamento e pressione OK, você será colocado para 

editar o símbolo em um palco vazio, utilize as ferramentas de desenho para criar 

seu símbolo, quando terminar, a partir do menu Edit, escolha Edit Document 
(Control +E), o símbolo será adicionado automaticamente à Biblioteca.

8.2 Editando um símbolo
Para editar um símbolo, abra a Biblioteca, dê um clique com o botão direito 

do mouse sobre o símbolo que quer editar, clique em Editar. Faça as altera-

ções desejadas e quando terminar, a partir do menu Edit, escolha Edit Do-
cument (Control +E). As instâncias de seu símbolo irão refletir as alterações.Instância é uma 

cópia de um sím-

bolo que se loca-

liza no Palco ou 

aninhado dentro 

de outro símbo-

lo. Uma instância 

pode ser bem 

diferente de seu 

símbolo quanto 

à cor, tamanho 

e função. Editar 

símbolos atualiza 

todas as suas ins-

tâncias. Porém, 

a editar uma 

instância de um 

símbolo só atuali-

za essa instância.

8.3 Editando uma instância
Ao alterar uma instância de um símbolo movendo, redimensionando ou adi-

cionando um efeito, esta modificação não irá afetar o símbolo original nem 

as outras instâncias. Selecione no palco a instância que quer alterar, no menu 

Color da Barra Proprierties escolha o efeito desejado.
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Você pode inserir 

mais efeitos a um 

símbolo através 

do menu Blend 

na Barra Proprier-

ties, escolha um 

efeito desejado.

•	 None: Não aplica qualquer efeito na instância;

•	 Brightness: Permite ajustar o brilho da instância. Um valor em 100 torna 

a instância branca. Um valor em –100 a torna preta;

•	 Tint (tonalidade): Permite dar a uma instância com a cor de sua escolha.

•	 Alpha (opacidade): Ajuste da transparência. Um valor em 0% torna sua 

instância completamente transparente. Um valor em 100% torna-a com-

pletamente opaca;

•	 Advanced: Permite ajustar simultaneamente tonalidade e transparência.
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Aula 9 -Trabalhando com Layers

9 Trabalhando com Layers (camadas)

As camadas são muito utilizadas em diversos programas gráficos por ofe-

recerem uma edição mais fácil e segura dos elementos que compõem um 

desenho ou filme.

No flash você deve inserir um novo Layer (camada) cada vez que animar um 

objeto dentro do palco, para que uma animação não acabe prejudicando a 

outra.

As camadas são como folhas de papel transparente sobrepostos, sendo que, 

a camada superior exibirá seu conteúdo em primeiro plano.

Sendo assim, se você quiser colocar um fundo em sua animação, este deverá 

ficar abaixo de todas as outras camadas.

 As camadas são dispostas uma sobre as outras na forma de empilhamento. 

Os objetos que estão na camada superior sempre aparecerão no palco acima 

dos objetos contidos nas camadas abaixo.

Ao iniciar um novo projeto, aparecerá sempre, como padrão, uma única 

Layer (denominada Layer 1) com sua linha do tempo. A partir daí você pode 

criar novas camadas para inserir novos elementos no palco.
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Insira 3 Layers no 

palco de nome A, 

B e C. Selecione 

a Layer A e dese-

nhe um quadrado, 

Selecione a Layer 

B e desenhe um 

círculo, Selecione 

a Layer C e dese-

nhe um Polygono, 

todos no meio do 

palco. Em seguida 

mova as camadas e 

confira o resultado.

9.1 Criando Layers
Clique sobre o botão Insert Layer (abaixo das camadas no canto esquerdo), 

ou clique com o botão direito do mouse onde deseja inserir a cama e escolha 

Insert Layer. A nova camada sempre aparece acima da camada atualmente 

selecionada.

9.2 Alterando o nome das Layers
Para alterar no nome de uma camada, clique 2 vezes sobre o nome da Layer, 
desta forma aparecerá o cursor do texto e você poderá editar o nome da 

camada e quando terminar aperte a tecla ENTER.

9.3 Excluindo Layers
Clique sobre o botão Delete Layer, ou clique com o botão direito do mouse 

onde deseja inserir a cama e escolha Delete Layer.

9.4 Movendo Camadas
Selecione a camada desejada, clique e arraste para cima ou para baixo até a 

posição desejada. Uma linha acinzentada indicará a nova posição da cama-

da. Solte o botão.
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Modo de Exibição de Camadas: As camadas do Flash possuem quatro mo-

dos de exibição.

1

2 3 4

•	 1 Modo ativo: Apenas uma única camada pode estar em seu modo ativo. 

Qualquer objeto desenhado ou importado será colocado nesta camada. 

Um ícone de lápis indica qual é a camada atualmente ativa.

•	 2 Modo oculto: Pode-se ocultar os elementos de uma ou mais camadas 

que estejam atrapalhando visualmente, por um determinado período. 

Para ocultar uma camada, clique sobre o primeiro ponto (à esquerda) que 

aparece junto ao nome da camada, acima deste ponto há um ícone de 

olho. Um X vermelho indica que a camada está oculta.

•	 3 Modo bloqueado: Bloqueando uma camada, você pode ver conteúdo 

dela mas não edita-lo, evitando qualquer alteração acidental. Clique so-

bre o ponto do meio, acima há um ícone de cadeado. Este mesmo ícone 

sobre o ponto indica que a camada está bloqueada.

•	 4 Modo contorno: Neste modo, o conteúdo da camada aparecerá ape-

nas como contorno. Clique sobre o ponto mais a direita para alterar o 

modo de visualização, acima há um ícone quadrado.

Se você clicar diretamen-
te nos ícones ao lado, 
todas as camadas rece-
berão o modo selecio-
nado. Exemplo: Clicando 
diretamente no ícone de 
olho todas as camadas 
ficarão ocultas.
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Aula 10 - Scene

10 Scene (cenas)

As cenas são como como páginas de um documento ou slides de uma apresen-

tação. Cada cena do Flash poderá ter seu próprio conteúdo e um único filme 

poderá conter qualquer número de cenas reproduzido na ordem em que foram 

colocadas.

As cenas servem para ajudar a organizar o conteúdo de um projeto. Podemos 

inserir, excluir, renomear e ordenar cenas durante o desenvolvimento do trabalho.

Ao abrir um novo arquivo todo o conteúdo do palco será atribuído à Cena 1 

(Scene 1).

Para exibir o Painel Scene, clique no menu Window > Other Panels > Scene 
(Shift +F12).

Duplicar Cena

Inserir Cena

Excluir Cena

10.1  Inserindo uma nova cena
Para inserir uma nova cena, exiba o painel Scene e clique no botão + ou cli-

que no menu Insert > Scene. Será inserida a Cena 2 (Scene 2). Para visualizar 

ou modificar as cenas, clique no botão Edit Scene, mais a frente de Scene 1.
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10.2 Renomear uma cena
Para renomear uma cena, exiba o painel Scene, selecione a cena que deseja 

renomear e clique duas vezes sobre ela, digite o nome desejado e aperte a 

tecla Enter para finalizar.

10.3 Excluindo uma cena
Para excluir uma cena, exiba o painel Scene, selecione a cena que deseja 

excluir e clique no botão lixeira.

10.4 Duplicando uma cena
Para duplicar uma cena, exiba o painel Scene, selecione a cena que deseja 

duplicar e clique no botão duplicar cena.

10.5 Movendo uma cena
Exiba o painel Scene, clique sobre a cena desejada, pressione o botão esquer-

do do mouse e arraste a cena até a nova posição, um pequeno traço indica 

a nova posição da cena. Solte o botão do mouse para finalizar o processo.
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Aula 11 - Introdução a animação

11 Animações.

A animação do Flash funciona da mesma maneira que uma película que 

compõe um filme. É composta de inúmeros quadros enfileirados, cada qua-

dro possui uma figura levemente modificada em relação à anterior, desta 

forma quando o filme é reproduzido, ocorre a ilusão de movimento.

As animações no Flash podem ser obtidas por dois métodos: frame a frame 
(quadro a quadro)  ou tween (interpolação).

11.1 Métodos de animação

•	 Frame a Frame: Este método envolve criar vários quadros-chave, um se-

guido do outro,  criando-se vários objetos, um em cada frame, e a visua-

lização sucessiva de todos os frames dá-nos a idéia de animação.

•	 Tween: Na animação tween só criamos o objeto inicial e o final sendo 

o flash a criar as imagens intermédias que permitam a animação. Trata-

-se de uma animação mais eficiente, que utiliza, da forma mais simples, 

apenas dois quadros-chave; o primeiro, que contém a imagem gráfica 

inicial e o segundo que contém a imagem gráfica final. O Flash então se 

encarrega de vincular uma imagem à outra.

Nas animações Twe-
en, você pode definir 
se sua animação será 
uma animação de 
movimento ou uma 
animação de forma. 
A primeira opção 
apenas desloca o 
objeto de um ponto 
a outro no palco. Já 
a de forma consiste 
em transformar um 
objeto em outro.

11.2 Time Line (Linha do tempo)
A Time Line é o local onde se define a velocidade da animação e a posição 

dos quadros que serão utilizados. Cada camada possui sua própria linha do 

tempo para que cada animação fique em uma camada separada.

Time Line
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Se quiser selecionar 

mais de um inter-

valo de quadros, 

pressione a tecla 

Shift enquanto clica 

sobre os outros in-

tervalos de quadros.

Um Keyframe 

(quadro-chave) é 

identificado por 

um ponto pre-

to. Os keyframes 

também podem 

estar vazios e são 

identificados por 

um ponto vazado.

11.3 Os Frames
A Time Line é dividida em frames e cada frame recebe um número para 

identificá-lo. Existem diferentes tipos de frame para realizar diferentes tare-

fas na execução de um filme.

•	 Frames vazios: São os frames que aparecem na linha do tempo quando 

você inicia um novo projeto.

•	 Frames regulares: Estes frames sempre são precedidos por um keyframe. 
O conteúdo deste keyframe se repete pelos frames regulares até que 

estes terminem ou até alcançar outro keyframe.

•	  Keyframes (Quadros-chave): São frames especiais onde ocorrem as alte-

rações de conteúdo ou animação (movimento, forma ou cor).

Keyframes

Frames Regulares

Frames Vazios

Crie um arquivo Novo, File>New, agora vamos importar um gif animado, 

clique no meu File > Import > Import to Library, escolha a imagem bone-

co_de_massa.gif , você deve baixá-la no ambiente virtual de aprendizagem.

O gif animado aparecerá dentro do painel Library no canto inferior direito.
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Note que, como o gif é animado quadro a quadro, são importadas todas 

as imagens necessárias para o movimento do boneco; estas imagens estão 

agrupadas em um símbolo, Symbol 1. Agora vamos clicar no frame 1 da 

Layer 1, agora vamos arrastar o Symbol 1 até o palco.

Em seguida selecione o frame 15 na time line, clique com o botão direito e 

escolha Insert > Frame ou pressione F5. Agora a imagem será exibida do frame 

1 até o frame 15. Crie mais um Layer, note que a Layer 2 será criado com 

frames vazios.

No frame 1 da Layer 2 iremos desenhar um balão com a ferramenta pencil 

indicando pensamento.

Note que agora os frames do Layer 2 não estão mais vazios e o balão se 

estende até o frame 15.

A partir de agora faremos desenhos dentro do balão com a ferramenta pen-
cil em alguns quadros do Layer 2.

Vamos começar no Frame 1 do Layer 2. Desenhe um sorvete dentro do balão.

Agora no Frame 5, clique com o botão direito do mouse escolha a opção Insert > 
Keyframe ou aperte F6, apague o sorvete deste Keyframe e desenhe um hambúrguer.
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Quando salvamos um 

projeto no flash auto-

maticamente este leva 

a extensão .fla, este ar-

quivo guarda todas as 

layers e projeto original 

para edição, quando fa-

zemos uma animação e 

apertamos Ctrl + Enter, 

ele automaticamente 

gera um arquivo .swf 

(de Shockwave Flash 

File), este pode ser visu-

alizado em uma página 

web usando um nave-

gador que o suporta ou 

através do Flash Player, 

que é um leve aplicati-

vo somente-leitura dis-

tribuído gratuitamente 

pela Adobe.

Depois no Frame 10, aperte F6, apague o hambúrguer e escreva: “Estou 

com Fome!”, escolha uma fonte e modifique o tamanho para 15.

Clique no Frame 15, aperte F6, deixe o mesmo texto só aumente seu tama-

nho para 22.

Agora aperte Ctrl + Enter para testar, depois salve em sua pasta.
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Aula 12 - Elaborando animações

12.1 Criando uma animação Frame a Fra-
me

Inicie um novo documento (File > New), selecione a ferramenta Text e digite 

no lado esquerdo do palco a letra “A”,altere o tamanho da fonte para 48, 

selecione a fonte e cor desejada.

Selecione o frame 2 na linha do tempo e clique em F6 para inserir um keyfra-
me, com a ferramenta Text ativada, dê um clique no lado direito da letra “A” 

para ativar o cursor de caracteres, digite a letra “D”, selecione o frame 3 e 

aperte F6 novamente. Com a ferramenta Texto ativada clique no lado direito 

da letra “D”. Digite a letra “O”. Repita todos estes passos corretamente até 

completar a palavra ADOBE FLASH. Quando terminar, teste seu filme.

Para testar um filme

Para testar o filme pressione a seqüência Ctrl + Enter. Sua animação será

executada. Para sair da visualização feche a janela.

12.2 Criando uma animação Tween for-
ma
Inicie um novo documento (File > New), Selecione o frame 1 desenhe um 

círculo no canto superior esquerdo do palco. 
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Agora clique no frame 25 e aperte a tecla F7 para criar um keyframe em 

branco. Desenhe um polígono abaixo do palco, no centro.

Em seguida clique no frame 45 e aperte F7 novamente. Agora desenhe um 

quadrado no canto superior direito.

Agora vamos criar a interpolação de forma, para isso, clique com o botão 

direito do mouse sobre o frame 24, onde tem um quadradinho e escolha a 

opção Create Shape Tween.

Faça o mesmo no frame 44.
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Para testar aperte Ctrl + Enter. Salve o arquivo.

12.3 Criando uma animação Tween mo-
vimento
Inicie um novo documento (File > New), agora vamos importar duas ima-

gens, você deve baixá-las na ambiente virtual de aprendigem, Clique em File 
> Import  > Import to Library, 

Escolha a imagem bola_de_basquete.gif, repita o processo e escolha a ima-

gem cesta_basquete.gif, as duas imagens irão aparecer no painel Library no 

canto inferior direito.

Insira mais um layer ao projeto e modifique os nomes do Layer 1 para cesta e 

Layer 2 para bola. Em selecione o frame 1 da camada cesta, clique e arraste 

a cesta para o palco. Agora selecione o frame 1 da camada bola, clique e ar-

raste a bola para o palco. Os objetos deverão ser posicionados como abaixo.
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Obs: Redimensione as imagens com a ferramenta Free Transform.

Agora selecione o frame 50 da camada cesta e aperte F6 para criar um qua-

dro chave.

Clique no frame 10 da camada bola e aperte F6. Arraste a bola um pouco 

mais para frente e abaixo do palco, depois selecione o frame 20 e aperte F6, 

posicione a bola um pouco mais a frente e acima do palco, agora selecione 

o frame 30 e posicione a bola mais a frente e acima como se fosse acertar 

a cesta, selecione o frame 40, aperte F6 e posicione a bola na cesta, para 

terminar selecione o frame 50, aperte F6 e posicione a bola abaixo da cesta.

Veja abaixo os movimentos que a bola deverá fazer.

Agora iremos adicionar o tween movimento. Clique no frame 9 da camada 

bola e com o botão direito do mouse e escolha a opção Create Motion Tween.

Repita o mesmo procedimento para os frames 19, 29, 39 e 49 da camada bola
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Para dar a ilusão 

que a bola está 

passando pela 

rede, você pode 

criar mais uma 

layer acima da 

camada bola e 

inserir um qua-

dro chave em 

branco(F7) no 

frame 45 desta 

nova layer e co-

locar a cesta na 

mesma posição 

da cesta que está 

na camada abaixo 

e depois apertar 

F6 para criar um 

quadro chave no 

frame 50 da ca-

mada criada.

Aperte Ctrl + Enter para testar e Salve a animação em sua pasta.

12.4 Criando um botão
Por meio dos botões, o usuário poderá interagir com o filme, criaremos um bo-

tão que altera sua cor quando o usuário move o ponteiro do mouse sobre ele.

Inicie um novo documento, crie uma nova layer com o nome de “botão”, 

selecione o layer 1 desta camada, clique no menu Insert > New Simbol, 

coloque o nome de  “bt_enter” e marque a opção Button no item Compor-

tamento e pressione OK.

A janela de edição de símbolos se abre, exibindo uma time line com uma 

layer. Esta time line é diferente das que já vimos. Ela possui quatro rótulos: 

UP (para cima), Over (sobre), Down (para baixo) e Hit (área), estes são os 

quatros estados do botão.

–– 	UP: indica o estado do botão quando ele estiver no palco (seu estado 

natural);

–– Over: indica o estado do botão quando o ponteiro do mouse se po-

siciona sobre ele;
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–– Down: indica o estado que é ativado quando o usuário clica sobre o botão;

–– Hit: define a área do botão que corresponderá aos movimentos e 

cliques do mouse, o conteúdo deste quadro é invisível, apenas delimi-

tando a área ativa do botão.

Selecione a ferramenta rectangle, em seguida modifique suas propriedades 

no painel properties, como segue abaixo.

Deixe a seleção sobre o frame UP e desenhe o retângulo no palco. Para cen-

tralizar o botão no meio do palco, selecione-o e clique no menu Window> 
Align, marque a opção To stage. Em seguida, clique nos botões Alinhar cen-

tro horizontalmente e Alinhar centro verticalmente. O círculo se posicionará 

no meio do palco.

a a

a

Agora com o retângulo selecionado, aperte Ctrl + D, em seguida clique no 

menu Modify > Transform > Flip Horizontal, em seguida tire a borda do re-

tângulo duplicado clicando na opção Stroke color do Painel Properties.
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Selecione a ferramenta Free Transform e diminua um pouco o retângulo 

duplicado.

Agora posicione o retângulo duplicado no centro do retângulo original.

Agora vamos inserir um texto ao botão. Selecione a ferramenta Text e digite 

no centro do botão o texto “Clique”.

Para inserir quadros-chave nos outros estados de botão, selecione o frame 
OVER e pressione F6 para inserir um Keyframe. Repita este processo para 

os outros dois quadros.

Agora selecione o quadro Over e modique a cor do botão selecionando o 

retângulo duplicado e modificando no painel Color, na caixa de cores, no 

canto superior direito.

Clique no frame DOWN e repita o processo modificando para uma cor di-

ferente das outras. 

Agora que o nosso botão está pronto, voltaremos ao palco principal clican-

do no botão Scene1.
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Agora o botão criado irá aparecer dentro da Library no canto inferior direito. 

Clique e arraste o botão para o palco. Depois aperte Ctrl + Enter para testar 

o mesmo. Salve o arquivo com o nome de “Botão_1”.

12.5 Adicionando sons aos estados do 
botão
Abra o arquivo “Botão_1”, dê um duplo clique sobre o botão que está no pal-

co, os estágios do botão serão exibidos. Crie uma nova layer nomeada “Som”. 

Nesta camada, crie um keyframe em cada estágio do botão, em seguida im-

porte o som desejado para a biblioteca, File > Import > Import to Library.
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: Baixe os sons no 

site http://www.

f l a shk i t . com/

soundfx/Interfa-

ces/Beeps/

Na Layer Som, selecione o frame Over, Clique no som e arraste até o palco.

Agora seguida selecione o frame Down, Clique e arraste da Biblioteca o ou-

tro som para o palco. Aperte Crtl + Enter.

12.6 Criando uma animação com Guia 
de Movimento
Quando você cria uma animação de movimento este seguirá sempre em 

linha reta, através das guias de movimento podemos criar movimentos ao 

longo de um caminho.

Com as guias podemos desenhar o trajeto que a animação irá seguir.

Atividade de Aprendizagem: Abra um arquivo novo, File > New. 

Crie dois layers, a layer abaixo renomei como “fundo” e a layer acima com o 

nome de “tartaruga”. Selecione o frame 1 da layer fundo, Clique em File > 
Import > Import to Stage, escolha a imagem “fundo_do_mar.jpg” e dimen-

sione a mesma do tamanho do palco. Agora selecione o frame 1 da layer 
tartaruga, Clique em File > Import > Import to Stage, escolha a imagem “tar-

taruga.jpg”, redimensione a mesma colocando-a no canto superior direito. 

Agora vamos estender todos os layers até o frame 40, clique no frame 40 de 

cada layer e aperte F6.

Em seguida clique na layer tartaruga com o botão direito do mouse e escolha 

a opção Add Motion Guide.
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Você pode criar 

uma nova ca-

mada acima 

do fundo com 

o nome de bo-

lhas e desenhar 

bolhas ao lon-

go do caminho.

Será criada uma guia de movimento acima desta layer e ela ficará vinculada 

a layer tartaruga. 

Selecione o frame 1 da camada guia de movimento. Com a ferramenta Pen-
cil desenhe uma linha curva como mostra a figura. Configure o lápis como 

Smooth na paleta Opções antes de desenhar.

Agora selecione a tartaruga e posicione-a no inicio do caminho, aparecerá 

um ponto quando você encostá-la na extremidade do inicio do caminho.

Selecione o frame 39 da guia de movimento e posicione a tartaruga no fim 

da trajetória. Em seguida clique no frame 39 da layer tartaruga, clique com 

o botão direito do mouse e escolha a opção Create Mtotion Tween.

Aperte Ctrl + Enter para testar e salve o projeto.
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Crie um novo ar-

quivo, adicione 

mais uma layer 

ao projeto, colo-

que o nome da 

primeira layer de 

balão e da se-

gunda layer de 

janela.

Vamos desenhar 

um pouco...

12.7 Criando uma animação utilizando 
Layer com Máscara
A layer com máscara permite ocultar algumas áreas e exibir outras que fazem 

parte do seu projeto , o que produz um efeito de animação muito atraente.

As layers de máscaras trabalham da mesma maneira que as layers de guia 

de movimento. Quando uma layer é determinada com máscara, as layers 
vinculadas à ela são chamadas de  layers mascaradas.

Tente desenhar um balão e uma menininha como abaixo no frame 1 da layer balão

Depois vamos pintar o desenho com a ferramenta Fill Color (balde de tinta), mas 

lembre-se, se tiver espaços abertos a tinta pode vazar, então aumente o Zoom 

(Ctrl +) para procurar possíveis falhas. Para diminuir o Zoom (Ctrl - ). Você tam-

bém pode pintar o desenho com a ferramenta Brush (pincel), coloque o modo 

do pincel em Paint Behind para que a linha fique na frente do preenchimento.

Em seguida coloque a menininha dentro do balão. Agrupe tudo e posicione 

o balão do lado esquerdo do palco.
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Agora vamos desenhar um quadrado no centro do palco dentro do frame 1 

da layer janela. Modifique o estilo da borda e preencha com a cor azul.

Crie uma animação selecionando o frame 40 das duas layers e apertando F6, em 

seguida clique no frame 40 da layer balão e coloque o balão do lado direito do pal-

co, fazendo com que o balão passe em frente à janela, depois clique com o botão 

direito neste frame e escolha a opção Create Motion Tween. Teste sua animação.

O balão passa na frente da janela. Agora, faremos com que o balão apareça 

apenas pela abertura desta janela.

Crie uma nova camada denominada Máscara. Nesta mesma camada, de-

senhe um retângulo sem contorno com uma cor qualquer que preencha 

exatamente a abertura da janela.

Vamos agora configurar esta camada como máscara. Clique com o botão 

direito sobre a layer máscara e escolha a opção Mask.

Agora teste sua animação e salve em sua pasta.
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Abra um novo 

arquivo, crie 2 

layers, uma com 

o nome actions 

e outra com o 

nome cursor.

Aula 13 - Interatividade

13 Interatividade

Utilizando interatividade, podemos permitir que os usuários interfiram em 

uma página controlando o filme da maneira desejada, reproduzindo, mu-

dando a aparência, inserindo dados em um formulário...

Para isso são necessários: um evento que irá desencadear uma ação, a ação 

desencadeada pelo evento e o alvo que será afetado pelo evento.

13.1 Eventos
Para que uma ação do Flash seja desencadeada, é necessário um evento que 

realize isso. Os eventos podem ser eventos de mouse, de teclado ou eventos 

de quadro.

13.2 Ações

As Ações são comandos que instruem o filme de Flash a realizar tarefas mais 

complexas. Elas tornam seu projeto muito mais eficiente. Utilizando uma 

linguagem chamada ActionScript, você pode parar, reproduzir, mover-se de 

um quadro para o outro, ou comandos mais avançados, como retornar um 

valor conforme o usuário interage com o filme de Flash.

No frame1 da layer cursor, faça o desenho de uma seta e rotacione a mes-

ma, será nosso cursor.
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Após criar o cursor iremos convertê-lo para um símbolo do tipo Movie Clip, para 

isto, selecione toda a imagem que será o cursor e converta para um novo símbolo 

apertando  a tecla (F8). Coloque o nome de cursor e escolha a opção Movie Clip.

Após criar um símbolo, devemos dar uma nome de instância, para o Movie-
Clip no stage. Um nome de instância é sempre necessário para podermos 

“chamar” e controlar este Símbolo (MovieClip) pelo Actionscript pra fazer 

uma determinada ação, função, método, etc.

Clique sobre a imagem que agora deve ser um símbolo do tipo “MovieClip”, 

no Painel Properties coloque o nome de instância de cursor1.

a

Agora que já temos criado nosso Movieclip com nome de instância cursor1, 

selecione o frame 1 da camada actions e abra o painel Actions apertando a 

tecla de atalho F9 ou pelo menu Window > Actions.

Insira o seguinte código:

Cursor1.startDrag(true);

Mouse.hide();

Agora modifique o número de quadros por segundo para 24, clicando no 

Frame Rate duas vezes. Iremos modificar esta quantidade para deixar mais 

fluente o movimento do mouse.
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a

Agora aperte Ctrl + Enter para testar e salve seu projeto.

Explicando o código : Na 1º linha do código colocamos o nome do Mo-
vieclip com nome de instância “cursor1”, em seguida, para este cursor 

acompanhar o movimento do mouse, utilizamos o método startDrag(). Isto 

fará com que o movieClip siga o cursor do mouse. Temos que definir entre 

“()””true”(verdadeiro) para acompanhar o exatamente o ponto de registro 

que definimos quando criamos o MovieClip. Se não declararmos “true”, o 

cursor irá seguir fora do ponto de registro do Mouse.

Na segunda linha, definimos que o cursor padrão do mouse irá “sumir” 

utilizando o Método hide(). Se não declaramos isso, irá aparecer o cursor do 

mouse e o efeito do mouse personalizado perde o sentido. 

e-Tec BrasilAnimação para web 89





Abra o projeto 

Boneco_de_

massa.fla,  Cli-

que no menu 

File > Publish 

Settings.

Aula 14 - Publicando um projeto

14 Publicando um projeto

Ao finalizar seu trabalho, você deve distribuí-lo em forma de páginas para 

a Web ou como um aplicativo independente. Este recurso é chamado de 

Publicar, que consiste em converter seu arquivo de autoria em diferentes 

formatos de arquivo para distribuição.

A maneira mais prática de realizar esta tarefa é utilizando a Caixa de diálogo 

Configurações de publicação.

Antes de pu-

blicar seu tra-

balho salve 

o projeto. Os 

formatos se-

rão adiciona-

dos na mesma 

pasta em que 

você salvou 

seu trabalho.

Na janela que aparece devemos selecionar os formatos que desejados ex-

portar. Vamos marcar a opção GIF image (.gif) e desmarcar as outras opções.

Note que atrás da guia principal temos outras guias de configuração con-

forme as opções escolhidas, em nosso caso teremos a guia GIF, clique nesta 

guia para verificarmos as opções.
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Selecione a opção Animated, que significa que nosso Gif será animado, você 

também pode modificar outras opções como quantas vezes quer que a ani-

mação se repita em REPEAT ou modificar opções de cores. 

Para obter uma imagem melhor e com fundo transparente selecione as op-

ções Optimize colors, Interlace e Smooth, e escolha as opções Transparent, 
Diffusion e Adaptive.

Em seguida clique no botão Publish e aperte OK. O arquivo Gif será enviado 

para a mesma pasta do arquivo fonte. Abra a pasta e confira o resultado.

14.1 Outros formatos.

14.1.1 Flash (.swf)

Utilize este formato para colocar seu filme do Flash dentro de um código 

HTML para visualizá-lo em um navegador.

Principais configurações neste formato:

Esta opção permite configurar a or-
dem em que as layers serão carrega-
das. Normalmente se utiliza o modo 
padrão, de baixo para cima.

Com esta opção ativada, o Flash gera 
um arquivo de texto com informações 
sobre os frames de seu filme e também 
a quantidade de dados em cada frame

Ative esta opção e outros usuários não 
poderão obter o arquivo .swf e con-
vertê-lo novamente para um arquivo 
de autoria .fla. Quando ativada, digite 
uma senha de proteção

Qualidade do JPEG define a qualida-
de das imagens bitmaps existentes 
no filme, quanto maior a qualidade, 
maior o arquivo.

14.1.2 HTML (.htm)
O código HTML é a linguagem utilizada para a criação de páginas para a 

Internet que o navegador traduz e exibe. A guia HTML permite configurar 

de que forma o filme será visualizado em um browser.

Principais configurações neste formato:
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O Flash oferece modelos utilizados para ge-
rar as páginas de HTML. A opção Flash Only 
(padrão) gera uma página HTML com seu fil-
me do Flash embutido nela.

Permite configurar as dimensões verticais e 
horizontais da janela do filme em que seu 
filme aparece dentro da página de HTML. 
Match Movie são a dimensões originais.  
Mas você poderá modificar esta opção para 
Pixels e Porcentagem.

Playback: Fornece opções que afetam o iní-
cio e durante a reprodução de seu filme na 
página de HTML. Como Pausado no início 
(inicia pausado e é exibido se o usuário cli-
car), Loop (Repetir), Display Menu (exibe 
um menu de controle se clicar com o botão 
direito do mouse e Device Font (substitui 
fontes de sistema serrilhado)

Quality: esta opção permite determinar como limitações de processador afetarão 
sua reprodução do filme em termos de velocidade e qualidade.
Window Mode: opção Windown (Reproduz o fime dentro de sua própria área 
retangular na página de HTML), Opaque (Permite mover elementos na página de 
HTML para trás da área retangular do filme sem que eles transpareçam) e Trans-
parent (Faz com que fundo da página HTML apareça em todas as partes transpa-
rentes do filme).
HTML alignment: Determina a posição do filme do Flash na janela no browser.
Scale: Define a disposição do filme dento dos limites especificados nos campos 
Largura e Altura.
Flash alignment: Essas opções determinam o alinhamento do filme dentro da ja-
nela do filme.

14.1.3 JPEG (.jpg)

É um formato muito utilizado em imagens fotográficas por renderizar me-

lhor os gradientes e por gerar arquivos de tamanho relativamente baixos.

Modifica a dimensão da imagem se a 
opção Match movie estiver desativada.

Determina a qualidade da imagem, quan-
to maior qualidade, maior o arquivo.
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14.1.4 PNG (.png)
O formato PNG (Portable Network Graphics) usa uma compactação ajustá-

vel, sem perdas, para exibir fotografias de 24 bits ou imagens de cores sóli-

das na World Wide Web e em outras mídias on-line. Foi desenvolvido como 

uma alternativa sem patente para o formato de arquivo GIF. O PNG suporta 

transparência em um canal alfa ou em uma cor designada. O melhor uso 

para o PNG é em documentos on-line, embora seu suporte a cores o torne 

mais indicado para documentos impressos do que o GIF. No entanto, os grá-

ficos PNG coloridos inseridos em um documento do InDesign são imagens 

de bitmap RGB e, portanto, só são impressos como composições e não em 

separações de cores.

14.1.5 Windows Projector (.exe)
Arquivos Windows Projector são filmes em Flash auto-executáveis. Sendo 

assim, o usuário não precisa do Flash Player para reproduzir o filme. Este tipo 

de arquivo é ideal para  distribuição de filmes em Flash em CD-ROM, DVD, 

dispositivos de memória USB e redes locais e remotas (LANs e WANs). Além 

disso, você pode distribuir seus filmes sem se preocupar com a versão Flash 
Player do seu público-alvo. 

14.1.6 Macintosh Projector
Se você deseja que o usuário execute o conteúdo do Flash em um Macin-
tosh, você deve marcar a saída de Macintosh Projector, desta forma são 

criados filmes auto-executáveis para Mac.

14.1.7 Quick time with Flash Track (.mov)
Você pode criar um filme no Flash e exportar para Quick time, este será 

executado no QuickTime Player. Arquivos .swf  também podem ser abertos 

diretamente e reproduzidos pelo QuickTime Player ou o QuickTime plug-in. 
Uma trilha de um filme do Flash pode ser misturada e composta com outras 

faixas QuickTime. 
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